Image 3

OldSkools ProMod Package Patch


Autor: Xoff. OldSkools es XVM, Damage Log, Hit Log, Capture Info, Sixth Sense Audio Mod, Fire Audio Mod, Extended Minimap.


Image 40

 • Jimb0s Crosshair
• ProMod SPG Sights
 ProMod SPG Angle Indicator

 Accurate Damage Indicator
• Serverseitiges Crosshair [an/aus Option]
 Zoomout Mod
 Freie Sniperansicht

Standard Damage Panel mit:

– Reperaturfortschritt
– Anzeige von Treffern
– Spieler Informationen




ProMod (2.2 Mb)

Share Button

Related posts:

75 thoughts on “OldSkools ProMod Package Patch

  1. Ich hab ein Problem , bei mir zeigts im Hangar keine Panzer an , Spiel startet und so weit funktioniert auch alles , nur ich sehe keinen Panzer mehr , kann nix mehr auswählen , nur mit dem letzten ausgewählten kann ich noch fahren.

    • Hat sich erledigt , hab vergessen die Häkchen rauszumachen. 😉 Aber aus irgendwelchen Gründen geht der Haetzer Flamer Sound nicht was ich stark vermisse 😉 kaqnn man da was falsch machen warum der net geht ?

  2. A small problem with this awesome mod. I want to hear my gun when I shoot. But it does a small “fass”. How can (or where) I modify that my gun sounds normally?

  3. This may or may not be a promod issue but I have never had this before. I was called away from my computer and when I returned, I have no tanks, no tank slots. There is a tank, the basic Japanese one, that I can go into battle with, but at the end of the battle I have to log out if I want to fight again in that tank.

    I did not touch the computer while not using it but I do have a cat who could have touched something.

    Please help me figure this out because I love this game and this mod is great but I can’t play now.

  4. My dad is a WWII vet (90 years old) and I think he’d like the WWII songs and new clips include in the promod garage ambient audio file. Any way to get them in mpg3 or some other easily playable format I can bun into a CD for him?

  5. New question:

    I have WoT installed in 2 directories so that I can play either NA or EU servers. Pro Mod only installs to the default directory so I can only use it with my NA acct. Is there a way to change the install directory so that I can put it on my EU directory as well?

    • you should be able to choose at beginning, i made 2 seperate founders for NA and EU, i also play RU server. i made 2 founders in my C: and that worked for me 😀

  6. danke danke!

    wie kann ich die funktion ausstellen-am besten die datei löschen(wo ist die denn ist die frage? :D)dass bei tastendrücken(wie zB “v” oder “q”)ein befehl im chat erscheint?

    bitte um antwort


  7. Hi,
    can you please make the installer window scrollable? I cant see the lower buttons and check boxes on my laptop. And I dont know how to access thoose.
    Pls find a solution for that.

  8. Hi,
    Is there a way how to change the color of damage done by platoon members? It shows in red color, which isn’t much helpful for orientation… (used to be orange = worked great).



  9. Question, in the game when looking at the opposing teams names in the upper right corner of the screen I see a symbol that looks like an eye. Not all of the players have this symbol. My team never has this symbol. The eye symbol changes from red to green. Sometimes its grey. What is this symbol mean? It’s driving me crazy!

    Also, after I installed this mod for the first time I was unable to select some of the optional items. I did a remove and re-installed the mod, but the options remained grey and un-selectable. Thanks!

  10. also der mod is der hammer und die gun sounds + garage und die WWII musik ist einfach der hammer^^

    kann ich nur empfehlen beide daumen hoch ^^

    @maximum hetzer Rage/flame sound funktioniert bei mir super^^

  11. when i start my promod.exe i can choose between german and english wich is all normal but when the mod selection screen opens i cannot click on 3/4 of the mods can someone help me??

  12. Sir, awesome work on this mod, but I have a problem configuring the xvm statistics. every battle the system informs me statistics are “inactive” yet i chose to have the active in the installer. Further using the xvm web editor to edit the config file fails to write a new config file and can not open the existing one. Is there some way to alter this? Thanks again for all your hard work.

    • i have the same problem,and every time i try to activate it ,awnsers me that “cant find configuration root”.i am tired of install and uninstall promod ,triyng fix the problem but nothing better.

  13. Any idea which damage panel this mod uses? I overwrote it accidentally with theJimb0 damage panel and I want this one back, but even installing this mod from scratch doesnt bring it back.

  14. Realy great mod, but with new realise, i have some problems. I did same as last time and now wot wont connect.when promod removed wot works…
    can somebody help

  15. Installed ProMod for 9.1, and WoT fails to launch!! It sits at the logon ‘connecting’ screen until I kill the client.
    Uninstall ProMod and the game launches OK… Oldskool, any ideas??????

    • Update:- Removed a few of the options and reinstalled. Seemed to log in OK!!
      Removed the following:
      Radial Menu Reload Script
      AutoEquip CamoNet…
      Tank Info Panel
      Sexy Battle Results Bot Detect Mod

      Didn’t choose any options from the second pop-up.

      Hope this helps.

  16. Like your mods but at any new version, game fail !
    just do the minimum you say and wot fail at “connexion” any idie ?
    just put dir of view, minimap and jimbo crosshair : does’nt work, sniff

  17. James says:
    June 12, 2014 at 8:47 pm

    Update:- Removed a few of the options and reinstalled. Seemed to log in OK!!
    Removed the following:
    Radial Menu Reload Script
    AutoEquip CamoNet…
    Tank Info Panel
    Sexy Battle Results Bot Detect Mod

    Didn’t choose any options from the second pop-up.

    Hope this helps.

    Read more

    Done all this but still wont connect, just connecting and connecting, what should i do with this promod? have worked fine before this new batch, can someone help me?im not the onlyone with this problem.

  18. What happened to the WWIIHWA configuration? The old one doesn’t work with 9.1 and I want stuff changed, like the “spotted” sound from german to English etc.. and the English voice reporting ive a new shell loaded. All the configuration options that used to come with WWIIHWA… can we have them back please, or how do we get to them?

    Other than that, excellent work.

    Maybe possible to refine the turret sounds to turreted tanks only though? A lot of tds the gun was moved by wheel / hand, not hydraulics, sounds kinda odd having my smaller tds guns move by hydraulics.

  19. Why the heck the download button must be hidden every freaking time? How hard it is to put clear and obvious “download from this button” to site?

  20. Hi, wann gibt’s die WWII Sounds wieder? Sind bei 9.4 ausgegraut. XVM zeigt auch keine WN8 mehr auf dem Players Panel an.

  21. hi , euer mod ist gut , ABER , warum habt ihr kein ZOOM INDICATOR, wo man DIE zoom grösse sehen kann , und warum funktioniert XVM nicht so richtig , ? beispielsweise , wenn das spiel anfängt , sieht man die STATS nicht , Viele Grüsse…

  22. Fucks up english audio.. German audio, shitty quality.. Now looking for default audio..

    Other features seem to be working fine.

  23. When can we expect a 9.7 update, game not much fun w/o my ProMod and by the way I love it and can’t seem to do as well w/o it thnx

    • When can we expect a 9.7 update, game not much fun w/o my ProMod and by the way I love it and can’t seem to do as well w/o it thnx Oh and u can answer to my E-mail if u wish

  24. HI guys i’m a big fan of your great mod. But i have a little problem, i don’t have the pen indicator in game on my crosshair. Is it normal?
    Thank you for helping me guys.


  25. I need help…! evriting is perfect BUT why players with 1500 wn8 are blue players after 1800 wn8 they must be bluo hov to change this pls somebody help…

  26. Ok…the mod worked…even if not completly…i could not see battle results in lower right corner…xvm statics were not working too….i was just tweaking witch mod i wanted so i repeated remove and then instal process…..BUT now it wont even work…at the end i just write Promode couldnt access some file. end. And i cant even see mod files in wot folder. So? where is problem?

  27. I just install the last version of your mod (9.8) but the installation fail at the end, i have a message saying that “Promod couldnt acces some file.” And then the mod said the installation is complete. But when i launch my game the mod aren’t in, and i don’t which file it misses.

    I try to lauche the ” Bei_Problemen.exe” to resolve my problem but at the start i have a message “ConsoleApplication1 stop running.”

    Plz help me. I’m a big fan of your work and your mod.

  28. Hey
    Just installed 9.8, but the does not show in the game. Then i tried “bei_problemen” but the launcher closed with an error and now I cant even reinstall Promod. The error reads msinet.ocx is missing.
    I installed the SD version of WOT.
    Pls help.

  29. Their website seems to be down, and mod installer downloads files from there i believe. So as source website is not accesible right now, no mod can be installed, that’s what i suspect anyway, which is a shame, cuz i really like promod

  30. Ok guys. I tried an other solution and it works. May be because the team oldskools fix it. If you Download the Promod DIRECTLY on their website ( ), the installation is complete Without any error message. But between this new installation of the mod, i upgrade my client to the HD version. It might be this. So try to reinstall with the file from the Oldskool website, and if it not run, try to upgrade your Wot client version and then reinstall the Promod.

    I hope it help you guys.

  31. Moin zusammen,

    folgendes Problem taucht bei mir auf; ich kann mit dem 8.9 mod nicht mehr per Mausrad in den snipermodus wechseln. Das ist total nervig, weil ich mich jetzt auf die Tastenfunktion umstellen müsste.
    Wie kann das Mausrad-Problem behoben werden?

  32. Promod does not work with the last update.

    It took 20 minutes to download promod . 20 minutes to install and nothing happens. Have not had this problem before and have downloaded the latest version.
    Usually it takes 30 sec . downloading and installing 2 min , and then it works as it shoul

  33. I have one cuestion,why i cant chose live ingame wn8 calculator anymore in your Promod,i love that thing and you remove it whyyyy???????

  34. Hi,

    Tks for your great work.
    Unfortunately, i cannot get the mods to work.
    Installation seems successfull but i only have a folder”audio” in my “res_mods\0.9.10” folder.
    Where are the main files ?
    Thanks for your response.

  35. Useful information. Fortunate me I found your site by accident,
    and I am shocked why this twist of fate did not happened earlier!

    I bookmarked it.

Leave a Reply

Your email address will not be published. Required fields are marked *